•  

    Hej.
    Mam pytanie może będziecie w stanie mi pomóc.

    Czy da radę zbudować rozbudowaną funkcję "wyszukaj pionowo", która będzie mi pobierała dane z kilku arkuszy?

    Np.
    Mam arkusz główny i chciałbym aby za pomocą funkcji podgrywało mi w nim dane z akrusza2, arkusza,3 arkusza4, arkusza5 itd.

    Aktualnie stanąłem na takim etapie
    =JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(A1;'Tabela1'!A:K;11;0); WYSZUKAJ.PIONOWO(A1;'tabela2!A:K;11;0))

    Niestety ta funkcja pozwala mi pobrać dane tylko z dwóch arkuszy.

    Następnie wyszukałem poniższą funkcję, aczkolwiek niestety nie chce mi działać
    jeżeli.błąd(wyszukaj pionowo(A1;'Tabela1'!A:K;11;Fałsz);"")&jeżeli.błąd(wyszukaj pionowo(A1;'Tabela2'!A:K;11;Fałsz);"")&jeżeli.błąd(wyszukaj pionowo(A1;'Tabela3'!A:K;11;Fałsz);"")

    Macie może jakiś pomysł jak powinna wyglądać poprawna funkcja?

    #excel #pytanie

    •  

      @nxxxk:
      Ja bym wrzucił wszystkie tabele do Power Query, tam scalił i wyszukał, ale jak koniecznie to chcesz robić zagnieżdżonymi nieczytelnie funkcjami -- to lepiej użyć =X.WYSZUKAJ(), tam masz opcję co ma zrobić, jeśli nie znajdzie wyniku -- zagnieżdżasz sobie kolejne X.WYSZUKAJ.

      źródło: Capture.JPG

      +: nxxxk
    •  

      @Polinik:
      Niestety mój poziom exela jest średni także nawet nie mam zielonego pojęcia jak działa power querty plus z pliku który mam na myśli działa kilka osób, także pobawię się tą funkcją x.wyszukaj, w każdym razie za pomoc.

    •  

      @nxxxk: PQ to moduł wbudowany w Excela, służy do pobierania, obróbki i transformowania danych, które można potem znów wypluć do arkusza Excela.
      W Twoim przypadku -- z poszczególnych tabel zaciągasz dane do PQ, jeśli tabele mają różne formaty i struktury -- w PQ doprowadzasz je do takiej samej formy, scalasz w jedną tabelę, następnie importujesz tabelę, którą chcesz uzupełnić, robisz w PQ odpowiednik WYSZUKAJ.PIONOWO() (tu to się nazywa relacjami, analogicznie do relacji tabel w SQLach) i taką uzupełnioną w PQ tabelę wypluwasz do arkusza Excela jako tabelę/tabelę przestawną.

      Jak coś Ci się w danych źródłowych zaktualizuje -- to na tabeli wynikowej klikasz tylko "Odśwież" i się automagicznie odświeża.

      +: nxxxk
    •  

      Niestety ta funkcja pozwala mi pobrać dane tylko z dwóch arkuszy.

      @nxxxk: Nie. Możesz pobrać dane z większej liczby arkuszy, ale zamiast drugiej WYSZUKAJ.PIONOWO musisz użyć JEŻELI.BŁĄD(WYSZUKAJ.PIONOWO(...))

      > aczkolwiek niestety nie chce mi działać

      @nxxxk: Druga formuła też musi działać, pod warunkiem, że zakresy wejściowe są podane prawidłowo a wyszukiwana wartość w którymś z nich występuje

      +: nxxxk

Gorące dyskusje ostatnie 12h